Turkey Citizens respond to Twitter censorship (via DNS)

Internet censorship is bad – especially when it is abused to censor media reports about potentially corrupt government officials. Luckily a lot of incompetent people try to implement censorship via DNS.

Censorship via DNS is a method which is pretty easy to bypass and some people have responded to this this:

http://mashable.com/2014/03/21/twitter-ban-turkey-graffiti/?utm_medium=feed&utm_source=rss

And no, I will not go into detail here on how to do it right – for obvious reasons….

 

 

Hacking Customer Quality Assurance

So I recently bought some (refurbished) Cisco equipment for my CCNA/CCNP lab, a 2620 and a 2621 to be precise. I bought both of them from the same company although there was a small, but important difference.

The 2620 placed in my first order went to my home address, but since I am building the Lab at my office I decided to have the 2621 shipped to my company address to spare me the logistics. Turned out this decision made quite a difference when both products arrived. (I bought the 2620 about 5 days ahead).

The 2620 could not boot the default IOS due to the following error:

System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)
Copyright (c) 1999 by cisco Systems, Inc.
TAC:Home:SW:IOS:Specials for info
C2600 platform with 16384 Kbytes of main memory

program load complete, entry point: 0x80008000, size: 0x403b9c
Self decompressing the image : #####....]
INSUFFICIENT MEMORY TO LOAD IMAGE!  
I/O memory percentage cannot be adjusted.

Checking the Cisco IOS Image downloads I noticed the requirements for the IOS Image on the shipped 2620 requires at least 32MB DRAM, like any other 2620 image listed there (bare minimum is 32MB Dram,8 MB flash). However the Router was only equipped with 16MB of DRAM making the Router unusable, even with the minimum feature IOS for the 2620.

Now since the Hardware was probably refurbished, it is clear that some memory was replaced/removed but not in a fashion that allows the Router to boot the IOS Image. Looks like somebody did not even boot up the Router to see if it works. Probably a mistake (to err is human, after all).

When my 2621 arrived (addressed to my company address) the package also included a “Testing Protocol” – basically a show version printed on a piece of paper. Someone actually took the time to boot it up, connect to the console port and copy & paste the output to add the print along with the product. As a customer, this ensures me that someone took the time to verify the functionality of the Router.

I do not now if that was just coincidence but it does seem to verify that depending on the shipping address quality assurance is handled differently. I will post an update on the situation.

But looks like the tl;dr of the whole story is: Use a corporate address if you can.